KNOWN ISSUE: Recording will sporadically get stuck (generally for WoW)
Incident Report for SquadOV
Resolved
This incident has been resolved.
Posted Jan 15, 2022 - 18:47 EST
Investigating
We are currently investigating this issue.
Posted Jan 15, 2022 - 11:38 EST
This incident affected: SquadOV (Desktop Client).